CB Defense Sensor: Unable to Login, Error: "ctiuser.dll is missing from your computer"
book
Article ID: 286415
calendar_today
Updated On:
Products
Carbon Black Cloud Endpoint Standard (formerly Cb Defense)
Issue/Introduction
- Upon login attempt, the error appears:
"The program can't start because C:\Windows\SysWOW64\ctiuser.dll is missing from your computer. Try reinstalling the program to fix this problem"
1/21/19 15:10:39: 1aac SiUtilGetWmiUUID: ERROR: CreateProcess failed: 2
ParseReplyHeader: errorCode = 0 (0x00000000), success = true
Environment
- CB Defense Sensor: 3.4.x.x
- Microsoft Windows: All Supported Versions
Cause
Corrupted install or upgrade attempt of the Sensor
Resolution
- If install/upgrade for Sensor failed and in Add / Remove Programs
- Uninstall CB Defense Sensor (https://community.carbonblack.com/t5/Knowledge-Base/CB-Defense-How-to-Uninstall-Windows-Sensor/ta-p/65560)
- Install intended Version of CB Defense Sensor
- Verify functionality
- If unable to uninstall the Sensor due to error messages or uninstall failure
- On Device that has the intended Sensor Version installed copy
C:\Windows\SysWOW64\ctiuser.dll
- Move this file to same location on affected Device
- Restart Device
- Verify functionality
Additional Information
If this issue occurs and the above Resolution does not allow normal login and ability to install Sensor please open a Support Case.
Feedback
thumb_up
Yes
thumb_down
No