App Control: Console timeouts and AD logins failing in 8.1.8 or 8.1.10 console
search cancel

App Control: Console timeouts and AD logins failing in 8.1.8 or 8.1.10 console

book

Article ID: 286292

calendar_today

Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • AD based logins and/or AD Policy mappings are enabled
  • Console logins timing out and failing with error message "Something Went Wrong"
  • Console pages flipping between home.php and dashboard.php
  • Increasing memory usage by Parityserver.exe, Lsass.exe and Svchost.exe
  • Windows System Events may show the server service crashing:
    The Cb Protection Server service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 5000 milliseconds: Restart the service.
  • PHP_Errors log shows:
    PHP Fatal error:  Maximum execution time of 240 seconds exceeded in C:\Program Files (x86)\Bit9\Parity Console\WebUI\include\SOAPUtil.php on line 71
    

Environment

App Control Server: 8.1.8 and 8.1.10

Cause

Caused by performance issues on encryption of secure LDAP queries

Resolution

This issue is resolved in our latest releases, so please upgrade the server app to version 8.5 or higher

The following temporary workaround exist until upgrade can be completed:
  1. Stop the CB Protection Server and Reporter Services
  2. Backup the "Classes.vbs" and the "QueryAD.vbs" files located here: 
    C:\Program Files (x86)\Bit9\Parity Server\scripts\
  3. Download the 8.1.6 versions of the Classes.vbs and QueryAD.vbs files
  4. Replace the existing files in the folder with the new ones
  5. In SQL Management Studio please run the following query to delete the database backup:
    use das; delete from dbo.file_streams where name = 'Classes.vbs'
    use das; delete from dbo.file_streams where name = 'QueryAD.vbs'
    
  6. Restart the server system

Attachments

Classes.vbs get_app
QueryAD.vbs get_app