App Control: Error 2502 & 2503 when attempting install / uninstall an app control agent
search cancel

App Control: Error 2502 & 2503 when attempting install / uninstall an app control agent

book

Article ID: 286240

calendar_today

Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

The following errors can be seen when attempting install / uninstall an app control agent:
 
Error 2502.Called InstallFinalize when no install in progress.
Error 2503.Called RunScript when not marked in progress.

 

Environment

  • App Control agents: All versions
  • Microsoft Windows: All versions

Cause

The issue can have multiple causes but the most commons are: 
  • Incorrect user grants over the folders C:\Windows\Installer and C:\Windows\Temp
  • Incorrect system date 

Resolution

  1. Made sure the date on the end point is correct. If the time is incorrect please follow the below steps:
    1. right click on the time  in the taskbar. 
    2. select adjust date/time.
    3. disable set time automatically .
    4. click on the change button in "set time manually".
    5. enter the time and date.
  2. Ensure the  following permissions are set  to the folders  C:\Windows\Installer and C:\Windows\Temp
    1. Right click on  C:\Windows\Installer folder and select properties 
    2. go to the security tab and apply the following properties:
      User or groupGrant 
      SYSTEMFull Control
      AdministratorsFull Control

 

Additional Information

A system reboot may be needed.