App Control: Error 2502 & 2503 when attempting install / uninstall an app control agent
book
Article ID: 286240
calendar_today
Updated On:
Products
Carbon Black App Control (formerly Cb Protection)
Issue/Introduction
The following errors can be seen when attempting install / uninstall an app control agent:
Error 2502.Called InstallFinalize when no install in progress.
Error 2503.Called RunScript when not marked in progress.
Environment
- App Control agents: All versions
- Microsoft Windows: All versions
Cause
The issue can have multiple causes but the most commons are:
- Incorrect user grants over the folders C:\Windows\Installer and C:\Windows\Temp
- Incorrect system date
Resolution
- Made sure the date on the end point is correct. If the time is incorrect please follow the below steps:
- right click on the time in the taskbar.
- select adjust date/time.
- disable set time automatically .
- click on the change button in "set time manually".
- enter the time and date.
- Ensure the following permissions are set to the folders C:\Windows\Installer and C:\Windows\Temp
- Right click on C:\Windows\Installer folder and select properties
- go to the security tab and apply the following properties:
User or group | Grant |
SYSTEM | Full Control |
Administrators | Full Control |
Additional Information
A system reboot may be needed.
Feedback
thumb_up
Yes
thumb_down
No