App Control: Error: "Update Failed" When Saving Rule
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App Control: Error: "Update Failed" When Saving Rule

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Article ID: 286212

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

When saving a rule the error "Update Failed" is received.

Environment

  • App Control (Formerly CB Protection) Console: versions lower than 8.0 patch 6

Cause

A change occurred in the database resulting in duplicate data.

Resolution

  1. Login to the App Control database server.
  2. Run the following query:
    USE das;
    SELECT name, COUNT(1) 'duplicate count'
    FROM [dbo].[state_groups] WITH (NOLOCK)
    GROUP BY name
    ORDER BY 2 DESC
  3. If any state groups have a 'duplicate count' value higher than 1, contact VMware Carbon Black support to address this issue. Example below:
    name	duplicate count
    ,5,6,	2

Additional Information

The issue was fixed 8.0 p6 however, if the issue existed before upgrading to a version later than 8.0 patch 6 it will still require help from support to resolve.