App Control: Agent Disconnected And Does Not Receive Configlist Updates Until A User Is Logged In
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App Control: Agent Disconnected And Does Not Receive Configlist Updates Until A User Is Logged In

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Article ID: 286107

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • Agent shows as Disconnected in the Console until a user logs in (remotely or locally) and/or
  • Agent fails to receive Configlist updates until a user logs in (remotely or locally)

Environment

  • App Control Server: All Supported Versions
  • App Control Agent: All Supported Versions

Cause

A network adapter or operating system setting is preventing the Agent from connecting (and receiving it's config list) until there is an active session.

Resolution

  1. Verify any VPN or Proxy settings that may require an active session before allowing network connections to the Server Address on port 41002.
  2. Verify the operating system's sleep/hibernation settings. (Windows, macOS)
  3. Verify the Ethernet Adapter Power Settings in the operating system. (Windows, macOS)

Additional Information

  • There are no settings in the Agent that would allow it to "wake" the endpoint when a Configlist change is available.
  • The Agent will rely upon the operating system's network settings.
  • If these settings cause an Agent to be deleted (Old Computer Cleanup) that machine will be automatically added back in to the Console when it is connected again.