Workload: Error:"The VDI feature is not enabled. Please contact your administrator"
book
Article ID: 286073
calendar_today
Updated On:
Products
Carbon Black Cloud Workload
Issue/Introduction
Clicking on "Carbon Black" under security, within the configuration menu in vCenter shows error: "The VDI feature is not enabled. Please contact your administrator" with no further option"
Environment
Carbon Black Cloud
Workload
vCenter: All Supported Versions
Cause
Missing API permissions
Resolution
Log into the Carbon Black Cloud console
Navigate to Settings > API Access > Access Levels tab
Click the "Edit" icon on the API access level that is is being utilized by the Workload Appliance.
Add Execute permission to “Manage host module on ESX servers”.
Add Read Permission to “Fetch ESX server details”.
Additional Information
If there is uncertainty on which API access level to edit, check the "API Keys" tab. Any keys that are associated to a Workload appliance will have a blue hyperlink in the "name" column.
The full list of required permissions can be found in the Workload guide under https://docs.vmware.com/en/VMware-Carbon-Black-Cloud-Workload/1.1/carbonblack_workload/GUID-9EA7512D-3841-45D4-9D12-E64C165373B3.html