CB Protection: Disabled or "Null" User Role Permissions
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CB Protection: Disabled or "Null" User Role Permissions

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Article ID: 286008

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Updated On:

Products

Carbon Black App Control (formerly Cb Protection)

Issue/Introduction

  • All logins receive "You Are Not Authorized to View This Page"
  • Login Accounts (Gear Icon) > User Roles tab has "null" or disabled roles

Environment

  • CB Protection Console: All Supported Versions
  • CB Protection Server: All Supported Versions

Cause

  • Removal of all permissions
  • Role set to disabled

Resolution

  1. Login to the CB Protection Server
  2. Open SQL Management Studio
  3. Run query:
    use das;
    select * from dbo.user_groups (nolock)
  4. Confirm if desired user role shows "0" under column "Enabled"
    • To re-enable run:
      update dbo.user_groups set enabled = 1 where user_group_id = <Insert User Group ID #>
  5. Confirm if desired user role shows "Null" under column "Permissions"
    • To re-set permissions run:
      update dbo.user_groups set permissions = 286795786207887359 where user_group_id = <Insert User Group ID #>
    • Warning: The above query sets the the permissions to the default "Admin- unified management" role settings. The permission will need manually adjusted in the console if a different level of permission is wanted