CB Defense: HTTP 400 Error When Configuring SAML
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CB Defense: HTTP 400 Error When Configuring SAML

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Article ID: 285486

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Updated On:

Products

Carbon Black Cloud Endpoint Standard (formerly Cb Defense)

Issue/Introduction

When attempting to configure SAML SSO in the web console, the configuration fails with the error "Request failed with status code 400" error message:
Request failed with status code 400

Environment

  • CB Defense Web Console: All Versions
  • SAML SSO

Cause

The X509 Certificate may not have been inserted correctly into the text field

Resolution

  • When copying the text from the X509 certificate into the input field, sometimes white space or a carriage return is being copied over. Try copying the cert information over individually line by line into the console.
  • Do not include the ---BEGIN CERTIFICATE--- and ---END CERTIFICATE---

Additional Information

  • Pasting the X509 Cert into a text editor prior to the console can help ensure the entire cert is displayed as one line, as well as to remove carriage returns and spaces. 
  • If this does not resolve the issue, please review: https://community.carbonblack.com/t5/Knowledge-Base/Cb-Defense-How-To-Troubleshoot-SAML-Configuration-Issues/ta-p/37013
  • If the above guide does not resolve the issue, please open a Support case