Workload: Veeam Backup on VMs fails with "Error: Failed To Parse /.CompanyCode"
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Workload: Veeam Backup on VMs fails with "Error: Failed To Parse /.CompanyCode"

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Article ID: 285114

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Updated On:

Products

Carbon Black Cloud Workload

Issue/Introduction

When sensor installed using cblauncher the Veeam backup fails while parsing guestinfo variables

Environment

  • Carbon Black Cloud Console: All Supported Versions
  • Workload: All Supported Versions
  • Microsoft Windows: All Versions
  • Linux: All Versions

Cause

Veeam fails to parse "/" in the CB guestinfo variables lines added to the .vmx config file upon sensor installation

Resolution

Veeam has been made aware of the issue and is taking steps to address it in a future release. This document will be updated once the issue is confirmed resolved. Until then, please use the below workaround to remove the guestinfo variables from the config file.
  1. Disable cblauncher
  2. Uninstall sensor
  3. Clear the guestInfo variables that belong to Carbon black in the VMX config file
  4. Reboot the guest VM
  5. Check the VMX file for guestInfo variables
  6. Once confirmed that guestInfo variables are removed, install sensors manually
Latest update (2022/01/10):
This issue should be fixed by upgrading to latest Veeam software release.

Additional Information

  • CWP appliance sets the following guestinfo variables, guestinfo.Cb/.CompanyCode and guestinfo.Cb/.ConfigURL
  • The listed variables are read by cblauncher
  • The reason to add "/" in guestinfo variables is that these variables are read-only for cblauncher