CB Defense for VMware: Virtual Machine Inventory not up to date
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CB Defense for VMware: Virtual Machine Inventory not up to date

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Article ID: 284926

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Updated On:

Products

Carbon Black Cloud Endpoint Standard (formerly Cb Defense)

Issue/Introduction

  • Virtual Machines that no longer exist appear in the Virtual Machines Inventory list in the PSC Console under Settings>VMware
  • Virtual Machine name or state is out of date
  • Virtual Machines may be missing from this Inventory

Environment

CB PSC Console: All Versions
CB Defense for VMware Appdefense: All Versions

Cause

This data is being synchronized from Appdefense. Therefore, changes to this list must be made in Appdefense. One likely cause is with the Appliance the Virtual Machines are on. If the Appliance is off in Appdefense, this will cause the Appliance to no longer sync its current state with Appdefense, resulting in both Appdefense and the CB PSC Console to remain out of date despite seeing a current sync time. 

Resolution

Ensuring the Appliance is on will allow changes made to Virtual Machines to sync with Appdefense, which will in turn update this Inventory list.
  1. Go to Settings>Appliances
  2. Locate the Appliance, and make sure it is turned on
  3. Confirm Appdefense data is once again synchronizing with the CB PSC Console (may take several minutes)

Additional Information

At this time there is no ability to make changes manually from the PSC Console, as this list is intended to be a reflection of what is currently in the environment.