ERROR: “Failed – Network error” with Long running requests with IBM WebSphere OM Web Viewer 12.1
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ERROR: “Failed – Network error” with Long running requests with IBM WebSphere OM Web Viewer 12.1

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Article ID: 28488

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Updated On:

Products

Output Management Web Viewer

Issue/Introduction

Long running Web Viewer requests, such as browsing a large APF report as PDF, can time out in WebSphere. The WebSphere servant log will display a series of messages culminating with BBOJ0124I.

Trying to download a report  and after nearly 5 minutes of downloading when a little more than 300 MB were downloaded it failed with below message: “Failed – Network error”

Some users report issues with downloading large production reports. When users use the "save" option at report around 200mb in Chrome/Edge downloading starts but after few minutes browser drops download with information : Failed - network error.

Environment

  • Output Management Web Viewer 12.1
  • IBM WebSphere Application Server

 

Cause

The  Maximum transaction timeout property is set too low and ConnectionResponseTimeout needs to be set.

Resolution

Long running Web Viewer requests can be timed out by WebSphere's thread hang recovery mechanism if they exceed a timeout value. The WebSphere servant log will display a series of messages, ending with this one:

 

BBOJ0124I:The Interruptible Thread Infrastructure timed out a request and it has become unresponsive, request ffffffff, request details: ThreadDetails: ASID = nnnn, TCB = 0X00nnnnnn, Request = ffffffff, Is JVM Blocked = false, Tried to interrupt = true, Given up = true, Internal Work Thread = false, Hung Reason = Dispatch Timer Popped, SR Dispatch Time = <date/time>, CTL Receive Time = <date/time>, CTL Queued to WLM Time = <date/time>, Request Timeout limit = 300, Elapsed Execution Time = 307, CPU Time Used Limit = 0, Outbound Request Timeout Limit = 180, ODI Details = [JVM INTERRUPTIBLE THREAD, Monitor ACTIVE]

Resolving this problem requires changing two timeout values. To do this:

  1. Log in to WebSphere's administrative console application.
  2. Under Servers > Server Types > WebSphere application servers, select the server which runs Web Viewer
  3. On the Application Servers panel, navigate to Container Services > Transaction service
  4. Change the Maximum transaction timeout property to a number of seconds which is greater than the expected longest-running Web Viewer request.

 

  1. On the Application Servers panel, navigate to Web Container Settings > Web container > Custom properties
  2. Add a property named "ConnectionResponseTimeout" and set it to a number of seconds which is greater than the expected longest-running Web Viewer request.

  1. Stop and restart your WebSphere environment so that the changes take effect.
  2. In the WebSphere servant log, verify that the following messages reflect the changes that you have made:

            BBOM0001I transaction_maximumTimeout: 1500
            BBOM0001I protocol_http_timeout_output: 1500