Configuration to check when Timesheets do not appear for a User
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Configuration to check when Timesheets do not appear for a User

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Article ID: 28441

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

User (resource) cannot see any open Timesheets. What reasons might Timesheets not appear for a resource?

Environment

Release: Any

Cause

Here are some of the possible reasons:
  • Resource is not 'Open for Time Entry'
  • Resource has a 'Date of Hire' or 'Date of Termination' - the application will not allow Timesheets outside this date range; if blank, all open periods will show
  • Track Mode for resource is not set to Clarity 
  • Resource is not set to active 
  • Resource does not have resource instance access rights: Resource - Self and/or Resource - Enter Time
  • There may not be any open Time Reporting Periods  

Resolution

After checking the configuration, have the User log into the application again and check for open Timesheets .   

Check User Access Rights:

  1. Log into the application as an administrator user
  2. Administration, Access and Organization: Resources link
  3. Search for and select the resource
  4. Check that the Status box is set to 'Active' (User Active Status)
  5. Click on the Instance link under the Resource's Access Rights Tab 
  6. Make sure that the resource has 'Resource - Enter Time' and 'Resource - Self' rights
  7. If the user wants to use the Mobile Time Manager application, check to ensure the user has the additional security access right to access this application from a Smart Phone -- Global Access Right = Mobile Time - Access
  
Check Resource properties: 
  1. Log into the application as an administrator user
  2. Home, Resources link
  3. Search for and select the resource 
  4. Check the 'Date of Hire' and 'Date of Termination' dates (timesheets will only show between these dates, if dates are entered)
  5. Check the 'Availability' field while you are here to make sure it is a valid number of hours (this allows for Task Assignment availability)
  6. Check the 'Track Mode' to make sure it is set to 'Clarity' (this value allows for Timesheet entry)
  7. Check the 'Open for Time Entry' field to make sure there is a check mark in the check box (this value allows for Timesheet entry)
  8. Check the Active box to make sure there is a check mark in the check box (Resource Active Status)
  
Check for Open Time Reporting Periods:  
  1. Log into the application as an administrator user
  2. Administration, Project Management: Time Reporting Periods link
  3. Search for 'Open' Time Reporting Periods
  4. If there are no results, check for 'Closed' periods
  5. Active 'Closed' periods or create new periods as needed