My newly configured AWS Account has cost data in Cost History so why is it showing as "No Current Billing"?
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My newly configured AWS Account has cost data in Cost History so why is it showing as "No Current Billing"?

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Article ID: 283785

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Updated On:

Products

CloudHealth

Issue/Introduction

This is likely due to configuration of a linked account instead of a consolidated billing account.

These are the conditions: 

  • Account Type shows as "No Current Billing"
  • Cost data is available in Cost History report.
  • Account status is Healthy. 

Possible causes:

Potential cause can be that the newly configured Account is a linked account of a Payer Account that is not yet configured in VMware Aria Cost platform.  Therefore the CUR is configured at linked account level which is not supported at the moment. 

Verification steps:

You can confirm this by going to Cost History at Partner level, filter to the newly configured account in question and select "Billing Account" as category and the table below should display "Unknown Accounts".  To investigate one step further, click on the drilldown amount for any month and observe the Payer Account ID is not the same as the LinkedAccount ID proving that this is a linked account.  

Resolution

At partner level, remove CUR configuration from the linked account and instead configure Payer Account found in drilldown statement from report above.  The ‘Account Type’ status will then be recognized as "Consolidated". 

Please review the following Knowledge Base articles that troubleshoot other scenarios where Account Type is "No Current Billing":

https://support.cloudhealthtech.com/hc/en-us/articles/14074991817741-Why-a-new-AWS-Account-that-is-healthy-showing-as-No-Current-Billing-and-cost-data-is-missing-in-the-Cost-History-report- 

https://support.cloudhealthtech.com/hc/en-us/articles/360016120951-Why-are-my-customers-AWS-Accounts-not-available-for-assignment-

https://support.cloudhealthtech.com/hc/en-us/articles/360018855891-Why-do-I-see-a-No-Current-Billing-error-message-