"Proxy with Token Expired" error
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"Proxy with Token Expired" error

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Article ID: 283031

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Updated On:

Products

DX OpenExplore

Issue/Introduction

DX OpenExplore(OE) UI shows Created by, <proxy_with_token_expired> on a Proxy(s). User has left the company and now proxy is failing to connect to OE(formerly known as Wavefront). 

Cause

If a token user's account permissions have been removed or the user account with the token associated is deleted, any API tokens associated with that account invalid and shown as TOKEN EXPIRED in the user interface (UI). 

Resolution

User with the Proxies permission can use their API Token to install a new proxy or update an existing proxy to resume connection to DX OpenExplore.  If the proxy should be managed by a Service Account, a super user or other privileged user, can use the Manage Service Accounts - Create a Service Account process to generate a new token or select an existing token to update the proxy configuration.

Checking the API response for the proxy will give details about user to whom the token belongs. Please note, once a user is deleted from OE you will not be able to find related information about the User ID.

Navigate to the following for more details

  • In OE Tenant, Go to Browse and select Proxies
  • Open Chrome or your preferred Web Browser
    • launch Developer tools,
    • Select Network
  • Select the proxy that shows token expired
    • Within the Developer tools click on Response

The response would be as shown below.

{"status":{"result":"OK","message":"","code":200},
"response":{"items":[
{
"version":"13.4",
"name":"Proxy on <hostName>",
"id":"########-####-####-####-#########",
"status":"ACTIVE","customerId":"<UserID>",
"inTrash":false,
"lastCheckInTime":1622021819042,
"hostname":"<hostName>",
"timeDrift":-4758,
"sshAgent":false,
"ephemeral":true,
"userId":"dev+<tenantName>@<domainName>",
"deleted":false,
"statusCause":""}

The proxies running with valid tokens would be having a valid userID value as below

{
"version": "13.4",
"name": "Proxy on <hostName>",
"id": "########-####-####-####-#########",
"status": "ACTIVE",
"customerId": "<userID>",
"inTrash": false,
"hostname": "<hostName>",
"lastCheckInTime": 1613708847689,
"timeDrift": -32,
"sshAgent": false,
"ephemeral": true,
"userId": "<userID@<domainName>",
"deleted": false,
"statusCause": ""
}

 

If the userId field isn't populated and showing <proxy_with_expired_token>  as shown below , it means the token in that proxy's wavefront.conf file belonged to a user that has been deleted from OE(formerly known as Wavefront).

{
"version": "13.4",
"name": "[TOKEN EXPIRED] Proxy on <hostName>",
"id": "########-####-####-####-#########",
"status": "ACTIVE",
"customerId": "<userId>",
"inTrash": false,
"hostname": "<hostName>",
"lastCheckInTime": 1613708845942,
"timeDrift": -69,
"sshAgent": false,
"ephemeral": true,
"userId": "<proxy_with_expired_token>",
"deleted": false,
"statusCause": ""
},

Additional Information