PAM Client Broken with Checking for update failed error
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PAM Client Broken with Checking for update failed error

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Article ID: 282583

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

The PAM client is installed on an RDP jump server. Users log on to the jump server and then launch the PAM client to access PAM. This used to work, but now all users get the following error when trying to connect to PAM:

"Checking for update failed. Reason: Can not open file ...\runtime-xxx\bin\server\classes.jsa

Environment

Applies to any PAM (client) release.

Cause

The RDP server admin installed the Dynatrace OneAgent. This agent has a known conflict with Java runtime environments. E.g. a Google search on "Can not open file classes.jsa" will return many results pointing back to the Dynatrace OneAgent. As of April 2024 examples are:

TIBCO Support article

Quest Support article

Informatica Community article

Resolution

If the Dynatrace OneAgent is not required on the PAM client host, uninstall it.

If it is required, turning off ProcessAgent injection should resolve the problem:

Additional Information

If you need the Dynatrace OneAgent and cannot turn off ProcessAgent injection, or turning it off does not resolve the problem for you, contact Dyntrace OneAgent Support to find a solution that works for you.