WSS Agent Status is showing 'Invalid or expired, customer access blocked' despite verifying CTC access
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WSS Agent Status is showing 'Invalid or expired, customer access blocked' despite verifying CTC access

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Article ID: 282575

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

WSS Agent Status is showing 'Invalid or expired, customer access blocked'  despite CTC being accessible.

CTC connectivity was verified using ping / telnet. 

This error usually appears if CTC requests get HTTP 400 response.  That can happen if the account is expired or invalid.  It can also happen with an old version the WSSA and you have configured to block legacy CTCv1 communication in Cloud SWG WSS Agent configuration global setting.  It can also happen if you are sending CTC requests through a proxy and the proxy is returning a 400 response for whatever reason.

However in this case we confirmed that none the above were occurring.

 

 



Environment

WSS Agent

Cause

The cause seems to have been a corrupted installation or some type of conflict with SEP.

Third party VPN was also removed from the machine and it did not make a difference either.

Resolution

CleanWipe was used to fully uninstall SEP and WSS Agent was also fully removed.

Thereafter, WSS Agent was installed and the error did no longer appear. SEP was also re-installed.