Delay in Enforce Console startup after DLP Manager Service Start
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Delay in Enforce Console startup after DLP Manager Service Start

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Article ID: 282542

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Updated On:

Products

Data Loss Prevention Core Package

Issue/Introduction

After restarting the DLP manager service, users are experiencing considerable delays in the Enforce Console startup, occasionally lasting over an hour. 

Environment

DLP Release: 15.x, 16.x

Cause

This affects Enforce systems for which end-users are loading the System > Servers and Detectors > Traffic page frequently and/or when the system has a lot of detectors configured.

The start-up of the Manager service can take a long time to complete without any obvious reason shown in the tomcat log, delaying the readiness of the service for end-users.

Upon closer inspection, you may notice that the Manager's main thread is spending a lot of time on the JFreeChartCleanup task:

10 Mar 2024 12:24:16,739- Thread: 29 INFO [com.vontu.manager.init.ServletInitTaskManager] Initializing task: com.vontu.manager.init.InitBusinessObjectTransformerFactory
...
10 Mar 2024 12:24:16,779- Thread: 29 INFO [com.vontu.manager.init.ServletInitTaskManager] Initializing task: com.vontu.manager.init.JFreeChartCleanup
...............  <= LARGE TIME GAP HERE FOR MAIN THREAD
10 Mar 2024 13:32:55,890- Thread: 29 INFO [com.vontu.manager.init.ServletInitTaskManager] Initializing task: com.vontu.manager.init.InitSystemUser

The Enforce system drive usage can also grow significantly until that slow restart occurs, with a large number of JPEG files sitting in the tomcat temp folder (Ex on Windows with DLP 16.0 RU1: C:\ProgramData\Symantec\DataLossPrevention\EnforceServer\16.0.10000\tomcatTemp).

Resolution

This is a Defect (CRE-17269) targeted to be fixed in DLP 16.1 and 16.0RU2

Workaround:

1. Reducing the utilization and/or refreshes of the Traffic page (System > Servers and Detectors > Traffic) on the web console

2. Deleting JPEG files whose name starts with 'jfreechart' in the tomcat temp folder (i.e. C:\ProgramData\Symantec\DataLossPrevention\EnforceServer\16.0.10000\tomcatTemp)

Steps: 
1. Open CMD and navigate to 'C:\ProgramData\Symantec\DataLossPrevention\EnforceServer\15.8.00000\tomcatTemp'.
2. Run the following command to delete all files starting with 'jfreechart' and ending with '.jpeg': 
del jfreechart*.jpeg.