error when trying to log into ITAM and starting Export/Import services
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error when trying to log into ITAM and starting Export/Import services

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Article ID: 282449

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Updated On:

Products

CA Service Management - Asset Portfolio Management

Issue/Introduction

The following error appears when starting the "CA Asset Portfolio Management - Export Service" service:

CA.Common.Data.Meta.Metadata' threw an exception.
System.TypeInitializationException: The type initializer for 'CA.Common.Data.Meta.Metadata' threw an exception. ---> System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.
   at System.Collections.Generic.Dictionary`2.get_Item(TKey key)
   at CA.Common.Data.Meta.Metadata.Instance.BuildClasses()
 

Environment

ITAM 17.x

Cause

Data has been deleted from the mdb manually

Resolution

We do not support deleting the fields in the database as it may cause data loss/inconsistency.  

We recommend restoring a database backup before the data deletion.