AIOps - Incorrect time of alarm creation in email notifications
search cancel

AIOps - Incorrect time of alarm creation in email notifications

book

Article ID: 282397

calendar_today

Updated On:

Products

DX Operational Intelligence DX OI SaaS

Issue/Introduction

We have noticed that the time in the email notification is displayed in the UTC time zone although it should be displayed as in the alarm view using the correct customer time zone, below an example:

1) From OI Alarms UI (alarm creation time = 9:42 am => CORRECT)

2) From email (alarm creation time = 7:42 am => INCORRECT)

Time from DX server: in UTC time

Environment

DX OI Saas

DX OI on-premise 2x

Cause

This is by design.
 
All time-related fields are stored in UTC/GMT timezone within elastic .
When rendering data in the UI, we dynamically convert these timestamps to the timezone of the user's browser. 
However, these time fields in emails, webhooks, or ticketing are sent based on the raw alarm payload (which is saved in UTC timezone)
 

Resolution

None.

Additional Information