TDM Portal - Failed to connect. The server replied: . undefined
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TDM Portal - Failed to connect. The server replied: . undefined

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Article ID: 282387

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

After upgrading TDM Portal, we aren't able to do anything when selecting the "Modeling" section of the Home page. We see all of our projects, and we see the Data Models under Modeling, but we get the following error displayed in red:

! Failed to connect.
The server replied . undefined

We aren't able to run data model scans, or create new environments. All other portions of the TDM Portal seem to work normally. We can see our Self-Service tiles, and run Find & Reserve.

 

Environment

TDM Portal all releases

Cause

After placing TDM Portal in DEBUG mode and checking the %ProgramData%\CA Test Data Manager Portal\logs directory for the "TDMModelService.log" file, we noticed that the log was never created. Checking the startup.log, we never see that the TDMModelService was started. There may have been corrupted cached files in the %CATDMWEB_HOME%\tomcat\webapps directory

Resolution

  1. Stop the CA Test Data Manager Portal service
  2. Make a backup of the %CATDMWEB_HOME% directory
  3. In a Windows File Explorer, navigate to the %CATDMWEB_HOME%\tomcat\webapps directory
  4. Delete all the TDM* subdirectories (DO NOT DELETE the ROOT subdirectory or the *.war files)
    These subdirectories get created when the Tomcat Service first starts, and reads in the war files. They contain cached data that sometimes can get corrupted.
  5. Clear the files in C:\ProgramData\CA\CA Test Data Manager Portal\logs
  6. Restart the CA Test Data Manager Portal service

If the problem persists, please open a support case by logging into the Broadcom Support Portal. Please provide a copy of the entire %ProgramData%\CA Test Data Manager Portal\logs directory in a compressed file (preferably while Portal is still in DEBUG mode). 

Additional Information

The latest TDM Portal patches are available for download at the Test Data Manager (TDM) Support Patches page