ServiceNow integration with Spectrum fails to create new tickets
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ServiceNow integration with Spectrum fails to create new tickets

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Article ID: 282384

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Updated On:

Products

Network Observability Spectrum

Issue/Introduction

Using a custom Notifier based integration to generate tickets in Service Desk ServiceNow (SNOW) based on DX NetOps Spectrum Alarms.

It was working but recently stopped. When trying to create a ticket manually in the OneClick java client or WebApp we see this error.

In the Notifier log file we see this error when it attempts to use the custom set, update, or clear scripts that issue curl statements to SNOW.

url: (35) schannel: next InitializeSecurityContext failed: Unknown error (0x80092012) - The revocation function was unable to check revocation for the certificate.

Environment

All supported DX NetOps Spectrum releases

Cause

The SNOW SSL Certificate has expired.

Resolution

There are two paths available to resolve this.

  1. The recommended path is ensuring the SSL certificates used by SNOW are not expired.
  2. The alternative is to utilize an option in the CURL commands issued that ignores certificate revocations (IE expired or otherwise faulty certificates not considered valid).
    1. NOTE: This is only available on Windows hosts running the Notifier scripts that issue the curl calls to SNOW.
      1. If Linux is used the SNOW certificate will need to be updated to resolve this.
    2. Modify the CURL syntax utilized to include the option "--ssl-no-revoke".
      1. This won´t error out because it will no longer check for SSL certificate revocation.
      2. NOTE doing so reduces security.

Additional Information

Additional information about the "--ssl-no-revoke" option is available via various public sources detailing CURL syntax options.

One example might be: https://stackoverflow.com/questions/54938026/curl-unknown-error-0x80092012-the-revocation-function-was-unable-to-check-r