dxserver fails to start
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dxserver fails to start

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Article ID: 282367

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

dxserver failed to start, no additional errors other than showing it failed to start.

1) enable debug by setting:           set trace = all      in DXHOME/config/logging/itechpoz.dxc.  Restart dxserver. With the trace option set, the logs should show trace or debug info. But, the traces are not getting enabled.  itechpoz-alarm  and itechpoz-warn are not getting updated either.

2) Verify if DXHOME/bin/dxserver     had sticky bit under root ownership,    Unix user dsa is local,  this user has r/x permissions on the file. 

3) Comment out references to secondary dxserver in DXHOME/config/knowledge/iTechpoz.dxg   (to remove high availability configuration), but this did not give any positive result.

4) ipaddress / host info  matches correctly in /etc/hosts  and ifconfig

 

Cause

dxserver normally runs as Unix user dsa. The dxserver log files, itechpoz.log  and itechpoz.alarm  files were owned by root and the unix user dsa did not have access to write to them.   

Resolution

1) reset file ownership on all the files in dxserver/logs to  have  RW  to Unix user dsa account

2) restart dxserver