The email user attribute is not populated correctly
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The email user attribute is not populated correctly

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Article ID: 282332

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Updated On:

Products

CA Identity Suite CA Identity Manager

Issue/Introduction

All user attributes are populated correctly except email attribute.

The Identity Manager mapping is set correctly in the Identity Manager Admin Console

Environment

Identity Manager 14.x

Cause

The root cause is the multivalue="true" in the UserStore and ProvStore xml files

Resolution

- From Identity Manager Admin Console, export the User Store and Prov Store XML files

- Search for the email attribute that is not being updated.

- Check if it has multivalue="true" parameter

 

Example of email attribute defined in the UserStore XML file

<ImsManagedObjectAttr physicalname="imStringXX" description="My Custom email" displayname="My Custom Email" valuetype="String" multivalued="true" wellknown="%MY_CUSTOM_EMAIL%" maxlength="0"/>

 

Example of email attribute defined in the ProvStore XML file

<ImsManagedObjectAttr physicalname="eTCustomFieldXX" description="Custom Field XX" displayname="Custom Field XX" valuetype="String" multivalued="true" wellknown="%CUSTOM_FIELD_XX%" maxlength="0"/>

 

- Remove the string multivalued="true" from both XML files and save them

- From Identity Manager Admin Console, reimport both XML files

- Restart Identity Manager service