Scheduled reports or discovery scans triggered at a wrong time after time zone changes on the Enforce server
search cancel

Scheduled reports or discovery scans triggered at a wrong time after time zone changes on the Enforce server

book

Article ID: 282304

calendar_today

Updated On:

Products

Data Loss Prevention Network Discover Data Loss Prevention Enforce

Issue/Introduction

You have recently changed the time zone settings on the Enforce server which shifted the time on the Enforce compared to the old time zone. This could be a time zone change, or enabling DST (Daylight Saving Time) automatic adjustment. After the change you noticed that the scheduled reports or other tasks, such as Discovery scans, are off by the difference between the old and new time zone settings.

 

Environment

15.8 or later.

Cause

The time zone information is saved along with the schedule of the task at the moment the report or scan is saved. This is not automatically readjusted after changing the time zone on the Enforce server. The result is that the report schedule remains in the old time zone, while the Enforce is using the new time. This results in a time shift between the report execution with the expected time of its execution equal to the time difference between one and the other.

Resolution

The resolution to the issue is resaving all reports, or other scheduled tasks, after changing the time zone on the Enforce and restarting the Symantec DLP Manager Service. This will save them in the current Enforce time zone and the time shift will be cleared.