Why is there a negative count in dashboard statistics?
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Why is there a negative count in dashboard statistics?

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Article ID: 282296

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Updated On:

Products

CA API Gateway

Issue/Introduction

The gateway dashboard in policy manager shows a statistic count as a negative number. Why is there a negative number and how to fix this?

Environment

All supported Gateway versions

Cause

The counter to hold the statistics on the database is a 32-bit integer and it appears the count is running beyond the allowed characters for a 32-bit integer.

Resolution

There is no fix for this as of Gateway 11 CR2 or 10 CR4 version. The future release of the gateway will have the counter with a 64-bit integer.