CAS9182A vs CAS9181A product LMPcode expiry message differences
search cancel

CAS9182A vs CAS9181A product LMPcode expiry message differences

book

Article ID: 282202

calendar_today

Updated On:

Products

Common Components and Services for z/OS

Issue/Introduction

In the 30 day period prior to Broadcom/CA product LMPcode expiry1 date we saw:
*CAS9182A - WARNING: LMP KEY PROD (xx)                      EXPIRES IN nnn DAYS
messages on interactive TSO sessions, in the z/OS operlog(syslog) and in OPSMVS log - 
but these did not accumulate  as alert/action messages on the z/OS console requiring the operator to clear

In period since expiry date 1 we now have:
*CAS9181A - ENFORCEMENT POSTPONED DUE TO DATE EXTENSION
messages on interactive TSO sessions, in z/OS operlog(syslog) and in OPSMVS log - 
and these DO accumulate as alert/action messages on the z/OS console that operator must continually clear

Can you please explain how/why the difference?

Environment

  • Common Services r15.0
  • OPS/MVS r14.0
  • LMP Keys at or near expiration date
  • Prior to the expiration date, CAS90182A - multiple messages are missing from the z/OS Console, OPSMVS log, interactive TSO sessions, in z/OS operlog(syslog)
    • Message written to OPSLOG and marked with DOM found in OPSVIEW display
    • The OPS/MVS DOM setting is defined as (Delete Operator Messages)
  • When the expiration date is reached, CAS90181A - messages are written to the OPSMVS log, interactive TSO sessions, in z/OS operlog(syslog)
    • Message is written to OPSLOG but no DOM marking in OPSVIEW display
    • Messages accumulate on the z/OS Console
      • Require operator action to clear the console  
         

 

Cause

  • CAS9 will display both messages on the console when executed.
    • A CAS9182A message is a warning
      • LMP will DOM the previous warning before issuing a subsequent message to prevent flooding the console.
    • A CAS9181A requires immediate action to be taken
      • LMP takes no action and allows messages to be written to the console
      • LMP operates in the same manner for a CAS9180E message indicating an unlicensed product  

 

Resolution

  • The CAS9181A is is considered to be more critical; immediate action is necessary
    • A reminder to take action now and request new keys
    • There is no LMP check for first or other instances and no WTOs are DOM'd.
    • Unless the customer suppresses the WTO in the SYS1.PARMLIB(MPFLSTxx) member or through OPS/MVS itself,
      the console operator has to delete them manually. 
      • Knowledge document 8095 provides the details for adding the message to SYS1.PARMLIB 
  • The CAS90182A message is listed as a warning
    • If a key is in the warning period, there is no need to possibly "flood" the console with warning messages.  
    • LMP processing will check if a warning has been previously issued. 
    • If true, LMP will set the DOM for the old one to prevent issuing another warning message.

Additional Information

Review the r14.0 OPS/MVS® Event Management and Automation Documentation for information on the DOM function
Review the r15.0 Common Services for z/OS Message Reference for information on the CAS9180E, CAS9181A and CAS9182A messages