Dispatch database "Broken Chain" preventative measures.
search cancel

Dispatch database "Broken Chain" preventative measures.

book

Article ID: 28220

calendar_today

Updated On:

Products

Dispatch Output Mgmt

Issue/Introduction

We have encountered a situation in which we are going to have to CANCEL the Dispatch started task.

Is there anything we can do to help prevent broken chains in the Dispatch database files?

 

 

Environment

11.7, Dispatch

Cause

The major cause of broken chains in the Dispatch database files is improper recovery procedures after the cancellation of the Dispatch address space or batch maintenance jobs. Arbitrary cancellation of these jobs is discouraged.

 

Resolution

If there is no alternative to canceling Dispatch or if an abend has occurred, we suggest following these steps:

 

* If the Dispatch address space was cancelled:

1). Before a batch job can update the IDMS database, restart Dispatch immediately so it can perform it's automatic roll back processing. For startup, issue the following START command  to ensure that none of the Dispatch subtasks are started:

  S Dispatch,START=DSSTAR00

2). Monitor the Dispatch startup messages to make sure you receive either a WARMSTART BYPASSED or a WARMSTART SUCCESSFUL message and no other errors.

3). After a successful startup of Dispatch, issue the  normal /xx 99STOPCADS command to shutdown cleanly.

4). From the Dispatch CADSJCL library, execute the DSEXDBAN utility to ensure you have no broken chains. In the submit JCL, make sure that you set all of the database area switches to 'LT'

* Broken chain error messages can be any of the following errors: 599701, 599702, 599703, or 599704. They typically contain the text 'NOT FOUND'. If broken chains are found, check to see if you have a current backup of this database area and contact CA/Broadcom Technical Support immediately.

5). If the DSEXDBAN output is clean, the indication is that canceling the address space did not create broken chains in the database files, so restart Dispatch using your regular startup command.

 As a followup - Research what might have caused the cancellation or abend in Dispatch. If further problems persist, contact CA/Broadcom Technical Support.

 


* If batch maintenance jobs (run with CA-Dispatch down) are cancelled or ABEND:

A). Check to see if the RESTORE steps of the maintenance procedure have executed. If not, resubmit the job with the symbolic parameter setting of RESTFI='LT'. This restores the database prior to the beginning of the run.

B). If the canceled or abended maintenance job was running against online viewing (job DSEXVIEW) we suggest running the DSEXOSY/DSEXOSYL "SYNC" utility using MODE=TEST to check for out of sync conditions between the LDS and OV database files.

Additional Information

Please refer to your CA-Dispatch System Programmers Guide, Chapter 11: System Backup, Recovery, and Maintenance

If all restore procedures have been followed and there are still broken chains, please contact CA/Broadcom Technical Support.