After upgrading from PAM 4.1.1 to 4.1.6 cannot login to PAM UI
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After upgrading from PAM 4.1.1 to 4.1.6 cannot login to PAM UI

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Article ID: 282106

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

After upgrading from PAM 4.1.1 to 4.1.6 PAM Admin on 2 our 6 pam appliances, PAM Admin cannot login to solution.

PAM Admin can login to PAM's config url and saw the following message flood their Tomcat logs:

2024-03-04T13:40:31.159+0000 SEVERE [Catalina-utility-1] com.cloakware.cspm.server.app.ApplicationImpl.<init> ApplicationImpl.initialize Initialization failed
    java.lang.NullPointerException
        at com.cloakware.cspm.server.app.ApplicationImpl.getIPv6Enabled(ApplicationImpl.java:1726)
        at com.cloakware.cspm.server.app.ApplicationImpl.initialize(ApplicationImpl.java:544)

2024-03-04T13:40:31.159+0000 SEVERE [Catalina-utility-1] com.cloakware.cspm.server.app.ApplicationImpl.shutdownNoMetric Shutting down - ApplicationImpl.initialize Initialization failed.
java.util.logging.ErrorManager: 4: Unable to create [logs]

 

Environment

PAM 4.1.6

Cause

Inside the uag.configuration_f.ipv6_enabled was NULL

Resolution

This issue is resolved in PAM future version of PAM:

4.1.8 and 4.2.0

Additional Information

Ultimately, we reset the PAM DB and ran another upgrade.  After this the issue was resolved.