VIP Enterprise Gateway Manager IdP login error: Patern not Matches, There is no mail attribute configured for the user with filter
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VIP Enterprise Gateway Manager IdP login error: Patern not Matches, There is no mail attribute configured for the user with filter

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Article ID: 282096

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Updated On:

Products

VIP Service

Issue/Introduction

Logging into the VIP Manager IdP portal on the VIP Enterprise Gateway fails with  "You have entered an invalid username and/or password. Re-enter the information and try again.

VIP Manager IdP server.log shows:

..."actor=JohnDoe ,op=Authentication,text=VIPMGRIDPFirstFactor:: Patern not Matches"

..."actor=JohnDoe ,op=Authentication,text=There is no mail attribute configured for the user with filter (&(&(&(objectClass=user)(objectCategory=person))(sAMAccountName=JohnDoe ))(|(memberOf=CN=VIPMgr_high\,OU=Application\,DC=example\,DC=net)(memberOf=CN=VIPMgr_ViewOnly\,OU=Application\,DC=example\,DC=net)))"

Cause

In the above example, the trailing whitespace following the User ID is used by the end-user and causes the failure.

Resolution

Check for white spaces and unusual special characters in the user ID. 

To confirm: Copy the user ID, verbatim, from the log file, then check it using the TEST button in the VIP Administrator Configuration settings.