Unable to access incident list in Enforce after 16.0 RU2 upgrade
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Unable to access incident list in Enforce after 16.0 RU2 upgrade

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Article ID: 282054

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Updated On:

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Issue/Introduction

After migrating to 16.0 RU2 from prior version, and successfully running the Enforce migrator to complete the upgrade.

On checking the incident list views you cannot bring up incident list.

Errors in tomcat log:

10 Apr 2024 14:31:26,615- Thread: 125 SEVERE [com.vontu.manager.ui.LogToServerController] loggedInUser:[Administrator], url:[/ProtectManager/ViewAllReports.do], browserInformation:[Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0], browserLocale:[en-US,en;q=0.5], userLocale:[en_US]
Javascript error at line 1: ReferenceError: removeCacheColumnByReportId is not defined

Environment

Enforce Server, 16.0 RU2

Seen after upgrading from 16.0 GA

Cause

This is due to a known Firefox bug:

Firefox still read old library file (.js) even if it updated | Firefox Support Forum | Mozilla Support

Firefox has an aggressive way to optimize performance.

All the js, css files only load the first time and as long as the file name and path not change the file won't get updated.

 

Resolution

The easiest workaround is ctrl+F5 (or other hot key combo in non-Windows OS) to force a reload of the page.

Another workaround is clear the browser cache:

How to clear the Firefox cache | Firefox Help (mozilla.org)

Additional Information

This is listed in the Release Notes, under "Enforce Server Known Issues in 16.0.2".