Authentication Required Error When Deploying API From Portal To Proxy
search cancel

Authentication Required Error When Deploying API From Portal To Proxy

book

Article ID: 282045

calendar_today

Updated On:

Products

CA API Gateway CA API Developer Portal

Issue/Introduction

Attempting to deploy any portal published API over to the gateway proxy fails and will then be placed into a 'Pending Deployment' state.

If we look at the details of why the deployment failed we will receive a 'Authentication Required' message.

Environment

Any supported version of the CA API Gateway and CA API Developer Portal

Cause

It was determined that the settings for port 8443 had been modified.

From policy manager->Tasks->Transports->Manage Listen Ports->choose port 8443 and select the Properties button->go to the 'SSL/TLS Settings' tab and the 'Client Authentication:' setting was changed to 'None'

Resolution

Change the Client Authentication setting to 'Optional' on the listen port.

The API Could then be successfully deployed from the Portal over to the proxy.

Additional Information

Currently the portal deployer functionality sends requests to port 8443 on the proxy gateway, this is not currently configurable.  There is a feature request to look into modifying this behavior in a future portal release such that the portal will be able to communicate with the gateway proxy over any desired port number.