"Oops something went wrong, please contact your administrator" when logging into Portal with OIDC
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"Oops something went wrong, please contact your administrator" when logging into Portal with OIDC

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Article ID: 282017

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Updated On:

Products

CA Identity Suite

Issue/Introduction

In an environment with Identity Portal integrated with Identity Governance, after adding OpenID Connect for Single Sign on in the Portal logging into the Portal generates an error "Oops something went wrong, please contact your administrator" after authenticating


OpenID Connect for Single Sign works as expected in Governance. 

Environment

Broadcom Identity Portal integrated with Broadcom Identity Governance 

Cause

Due to not having a Connector Login Source to identify the user being passed from Portal into Governance.  

Resolution

To resolve this issue the CAIG connectors Connector Login Source setting was updated. 

The specific attribute that is required will depend on the Single Sign on configuration.   For example, if the Single Sign On is using Email to authenticate update the the CAIG connector's Connector Login Source to  'Matching attribute = email' 



Additional Information

In a multiple node environment, after making this change, clear the cache on all nodes. 

Open Portal Admin, select Tools > Clear Cache > Check Select All > Press Clear Cache button.