Recipient User Groups are removed while importing CALL Objects via REST API
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Recipient User Groups are removed while importing CALL Objects via REST API

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Article ID: 282000

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Updated On:

Products

CA Automic Workload Automation - Automation Engine Autosys Workload Automation CA Automic One Automation

Issue/Introduction

When a user exports a CALL object using the REST API's GET request, all recipient information—including "User," "Email," and "User Groups"—is successfully included in the resulting JSON file.

Example GET Request:

GET http://<hostname>:<port>/ae/api/v1/<client>/objects/<object_name>

However, when the user re-imports the same object using a POST request through the REST API, the recipient type "User Groups" are not retained. Only "User" and "Email" recipients are correctly imported.

Example POST Request:

POST http://<hostname>:<port>/ae/api/v1/<client>/objects?overwrite_existing_objects=true

The issue is not present while doing an XML import/export.

Environment

Release: 21.x 

Component: Automation Engine 

Cause

The issue has been confirmed to be a bug by our Dev team.

Resolution

Update to a fix version listed below or a newer version if available.

Fix version:

Component(s): Automation Engine 

Automation.Engine 21.0.9 HF2 -  Available 

Automation.Engine 24.1.0-  Available 

 

Additional Information

Defect ID: AE-36535
Defect Desc: A problem has been solved where User groups were not saved when importing CALL objects via REST /objects endpoint.