Users with the assigned role can view but not edit Application Detection configurations
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Users with the assigned role can view but not edit Application Detection configurations

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Article ID: 281987

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Updated On:

Products

Data Loss Prevention Cloud Detection Service for REST

Issue/Introduction

Users with the assigned role, can view the list of the application detections configured, but they can not edit any of them.

If they click on them, they get the red banner with error:

"An unexpected error has occurred. This could be due to one of the following: 1) Your session timed out and you selected a link that was no longer valid ..."

Environment

Any supported version of DLP.

Cause

In this case, users had the "Application Detection Control" privilege, but no rights for "Server Administration".

This is because with editing rights, you can assign policy groups to a DLP Detection Server - the Cloud Detection Service for CASB.

Resolution

To be able to both view and edit Application Detection configurations, ensure both of the following privileges are enabled:

  1. On the "General" tab, under User Privileges: "Server Administration".
  2. On the Policy Management tab: "Application Detection Control".