Internal users are getting a certificate POP-UP box when access API endpoints
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Internal users are getting a certificate POP-UP box when access API endpoints

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Article ID: 281929

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Updated On:

Products

CA API Gateway

Issue/Introduction

Internal employees navigating to our main website are now getting prompted to select a certificate.  This started occurring with no changes on Gateway.

Environment

Gateway 10.x & 11.x

Cause

New personal certificates were added to internal employee browsers

The POP-UP  is occurring at the listening port level, the default SSL/TLS Setting for Client Authentication is set to Optional - (NOTE if this is changed to “None” the prompt will no longer occur, however this change is global for the listening port and may affect other endpoint authentications) 

Resolution

Two options to resolve 

Option 1 

When this is Optional and the browser has multiple personal certificates installed the client/user will be prompted to select one of the certificates.  If you check “Remember this decision” the browser will no longer prompt for certificate.

Firefox example:

 

The certificate is added to the Authentication Decision

Option 2

Delete all other certificates leaving only one 

Verified if ONLY one certificate is present NO prompt will occur