Newly installed agent on a windows server will not start
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Newly installed agent on a windows server will not start

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Article ID: 281892

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

We installed a new 12.x agent on a Windows 2016 server.
It will not stay started.
We see the following in the nohup.stderr
Exception in thread "main" java.lang.UnsatisfiedLinkError: RunnerPluginOS (Not found in java.library.path)
    at java.lang.ClassLoader.loadLibraryWithPath(ClassLoader.java:1472)
    at java.lang.ClassLoader.loadLibraryWithClassLoader(ClassLoader.java:1423)
    at java.lang.System.loadLibrary(System.java:629)
    at cybermation.agent.CybOSComponent.<clinit>(Unknown Source)
    at cybermation.agent.CybAgentDriver.main(Unknown Source)

We have tried the following but it has not resolved the issue.

Uninstall the agent
Reboot the server
remove any old directories
Disable any antivirus software
Run the installer again as ADMINISTRATOR.

 

Environment

Windows Server
autosys Agent 12.x

Cause

Environment Path is too long and a timeout is happening.

Resolution

Edit the system PATH.
Add the agent root directory and BIN directory to be first in the path.
Example:
C:\Program Files\CA\Workload Automation AE\SystemAgent\WIN_AGENT\
C:\Program Files\CA\Workload Automation AE\SystemAgent\WIN_AGENT\bin

NOTE:
A restart of the server may be required to have the new PATH applied.

This should allow the agent to start.

Additional Information

You can use Windows ProcMon to monitor the agent startup and see the process timing out looking for RunnerPluginOS.dll