After a reboot of the Primary scheduler the as_server will not stay up.
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After a reboot of the Primary scheduler the as_server will not stay up.

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Article ID: 281723

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

After OS patching we restarted the Primary Scheduler server.
The scheduler is up and running and processing jobs.
The APP server (as_server) starts and then dies a few minutes later.
Sometimes a CORE dump is generated.

The following error is seen after the as_server startup process is completed:
[04/05/2024 11:18:56]      CAUAJM_I_30001 AutoSys Application Server startup complete.
ORA-24550: signal received: [si_signo=11] [si_errno=0] [si_code=1] [si_int=0] [si_ptr=(nil)] [si_addr=0x1]
kpedbg_dmp_stack()+394<-kpeDbgCrash()+204<-kpeDbgSignalHandler()+113<-skgesig_sigactionHandler()+258<-__sighandler()<-__GI_____strtoll_l_internal()+58

Environment

Autosys 12.x
EEM 12.x

Cause

EEM SAF files were causing a problem with the as_server staying up and running.

Resolution

The as-server seems to be crashing when dealing with the EEM SDK.
It appears that it is during the process of handling the EEM SAF audit files.

In previous cases, we have seen where the as_server will crash or have a performance issue
if the number of files is too large or if they are not owned by the correct user.

Next steps:
1) if the as_server is started stop it.
2) go to the %AUTOUSER/audit
3) backup all the files in this location to another location
4) delete all of the files in this location
5) start the as_server as normal

To prevent this from happening in the future please follow the below KB article:
How to disable the creation of the EEM SAF Audit file creation in Autosys 12.x