Random SSL/connection related client pop up errors on the RMI registry port
search cancel

Random SSL/connection related client pop up errors on the RMI registry port

book

Article ID: 281702

calendar_today

Updated On:

Products

CA Automic Applications Manager (AM)

Issue/Introduction

The below errors or other similar SSL errors may be seen as an RMI pop up error in the Java Client. These error may or may not cause any adverse affects.

ErrorMsg: AwE-5102 Agent error
Details: Socket[addr=/<remote host/IP>,port=60278,localport=1099]
javax.net.ssl.SSLException: Unsupported or unrecognized SSL message

ErrorMsg: AwE-5102 Agent error 
Details: Socket[addr=/10.0.0.1,port=36394,localport=1099]
javax.net.ssl.SSLHandshakeException: Remote host terminated the handshake

ErrorMsg: AwE-5102 Agent error 
Details: Socket[addr=/10.0.0.1,port=36496,localport=1099]
javax.net.ssl.SSLHandshakeException: Client requested protocol TLSv1.1 is not enabled or supported in server context

ErrorMsg: AwE-5102 Agent error 
Details: Socket[addr=/10.0.0.1,port=36514,localport=1099]
javax.net.ssl.SSLHandshakeException: Client requested protocol SSLv3 is not enabled or supported in server context

 

Cause

Can be caused by a process attempting to communicate to port 1099 on master server. This could be an agent process, or an unknown external process such as a network scanning tool.

Resolution

Review the remote host/IP values listed in the errors(shown as example 10.0.0.1 above). It is usually the same host/IP value.

If the host/IP value is unrecognizable, refer to the Network Admin to determine what process on that server is trying to reach to the master's RMI registry port (default 1099).

This issue commonly occurs if there is a antivirus/network/ scanning tool that is running from said IP which is scanning port 1099 on the master server.

If this is found to be the issue, it is recommended that port 1099 be omitted from scans.