Meraki devices are not showing up in DX NetOps CA Performance Management (CAPM) Dashboards
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Meraki devices are not showing up in DX NetOps CA Performance Management (CAPM) Dashboards

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Article ID: 281663

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Updated On:

Products

Network Observability Virtual Network Assurance CA Performance Management

Issue/Introduction

There are no CPU or Memory metrics from Meraki Virtual Network Assurance (VNA) plugin and many devices are not shown:

Other issues are:

  1. It’s showing all Access Point, wether it came from VNA or SNMP
  2. It shows all WLC, whether from VNA or SNMP
  3. While clicking on any severity, it does not show Wi-Fi Alarms

Environment

DX NetOps CAPM & VNA 23.3.x

Cause

The Meraki VNA plugin doesn't support some metrics such as CPU and memory. The list of supported metrics is:

TechDocs : DX NetOps VNA 23.3 : Collected Performance Metrics

This dashboard is common for all plugins, regardless of wether they support the metrics or not:

So if the metric isn't supported, it will just show "No Data to display".

Resolution

Regarding the Dashboard issues:

  1. Issue - It’s showing all Access Point, wether it came from VNA or SNMP.

    Portal always tend to show items consolidated and will not try to differentiate the data-sources. So, it would list all the APs and WLCs, both from VNA and SNMP. However, we can filter based on the groups (e.g, All Groups -> VNA Domains --> <Specific_group>) if we are aware of the source.

    The Devices here are aggregated based on the 'Current Alarm State' of APs (or WLCs) in Portal. The current alarm state for the devices is synced from Spectrum to Portal.

    The "Wireless Access Point Devices" list can be sorted on 'Current Alarm State' column to identify the devices with the required state.



  2. Issue - While clicking on any severity, it does not show Wi-Fi Alarms

    Check if there are any alarms before clicking on the severity, Clicking on alarm severity in PIE chart will only apply the filter on the existing alarms that were synced from Spectrum to Portal for the AP or WLC devices.

    Also check main the 'Alarms Console' (from Top Bar Menu) to see if there are any wifi device alarms listed.



  3. Issue - Dashboard doesn't show Availability of AP’s where we know that Status is available in Data and it’s shown under Inventory -> Wi-Fi Devices Context.

    For the APs, the availability metric has to be polled/updated for this view to be shown. Check for any on the APs on the DA admin page, that the Availability MF is associated:

    Administration -> Monitored Devices Management -> Monitored Devices -> Search

    Search with IP or host name of one of the APs and select it. On the right hand tabs, select 'Polled Metric Families'.