No data seen in System Health Reports and don't see any Collectors in the Collector admin page
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No data seen in System Health Reports and don't see any Collectors in the Collector admin page

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Article ID: 281636

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Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

Mysql and Vertica data was copied to a separate staging environment and we are not seeing any data on the system health screens and not seeing any data collectors in the data collector admin screen.  The following exception was seen in the PCService.log:

 

ERROR | RIB/VendorCertsCacheScanner | 2024-04-01 13:50:13,840 | com.ca.im.portal.plugins.polaris.cache.utils.DAWsCacheUtils      
      | Error while connecting to https://xx.xx.xxx.xxx:8582/genericWS/certifications
com.ca.im.portal.plugins.polaris.utils.HTTPWebServiceRequestException: javax.net.ssl.SSLHandshakeException: No subject alternative names matching IP address xx.xx.xxx.xxx found
    at com.ca.im.portal.plugins.polaris.utils.HTTPWebServiceDispatcherImpl.makeRequest(HTTPWebServiceDispatcherImpl.java:340) ~[portal.console.plugins.polaris-22.2.5-RELEASE-1037.jar:?]
    at com.ca.im.portal.plugins.polaris.cache.utils.DAWsCacheUtils.performHttpRequest(DAWsCacheUtils.java:150) [portal.console.plugins.polaris-22.2.5-RELEASE-1037.jar:?]
    at com.ca.im.portal.plugins.polaris.cache.utils.DAWsCacheUtils.performHttpGetRequest(DAWsCacheUtils.java:99) [portal.console.plugins.polaris-22.2.5-RELEASE-1037.jar:?]
    at com.ca.im.portal.plugins.polaris.cache.vendorcerts.VendorCertsWsDispatcher.getVendorCertsXml(VendorCertsWsDispatcher.java:130) [portal.console.plugins.polaris-22.2.5-RELEASE-1037.jar:?]
    at com.ca.im.portal.plugins.polaris.cache.vendorcerts.VendorCertsWsDispatcher.getVendorCerts(VendorCertsWsDispatcher.java:91) [portal.console.plugins.polaris-22.2.5-RELEASE-1037.jar:?]
    at com.ca.im.portal.plugins.polaris.cache.vendorcerts.VendorCertsScanner.doRun(VendorCertsScanner.java:123) [portal.console.plugins.polaris-22.2.5-RELEASE-1037.jar:?]
    at com.ca.im.portal.plugins.polaris.cache.vendorcerts.VendorCertsScanner.run(VendorCertsScanner.java:89) [portal.console.plugins.polaris-22.2.5-RELEASE-1037.jar:?]
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:?]
    at java.util.concurrent.FutureTask.runAndReset(Unknown Source) [?:?]
    at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source) [?:?]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:?]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:?]
    at java.lang.Thread.run(Unknown Source) [?:?]
Caused by: javax.net.ssl.SSLHandshakeException: No subject alternative names matching IP address xx.xx.xx.xxx found

Environment

DX NetOps CA Performance Management (CAPM) all currently supported releases

Cause

Symptom: With more and more users enabling HTTPS and the upgrade to Jetty 10, there are more instances of SNI errors being seen after upgrades. This is due to the value of the Web Site Host and Web Service Host properties not being in the HTTPS certificates. One reason is that the migration and disaster recovery script uses IPs instead of FQHNs.
Resolution: With this fix, the update_pc_da_database_references.sh script now requires the FQHN hostname instead of an IP address. In addition, it now updates the four service properties files that include the hostname for NetOps Portal and the event manager to use the newly-provided FQHN. (23.3.4, DE578921, 33550366)

Resolution

1. Update DA data source to FQHN

2. Update EM to FQHN

3. Launch /opt/CA/PerformanceCenter/SsoConfig and update Web Site/Service Host to FQHN to resolve any SAN issues.

4. Log out of the Portal, then close and reopen the browser

 

You should start seeing data again