Remote Push Deployment fails with an error "Deployment Failed"
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Remote Push Deployment fails with an error "Deployment Failed"

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Article ID: 281471

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Updated On:

Products

Endpoint Protection

Issue/Introduction

When attempting to push Symantec Endpoint Protection[SEP] client install package through the push deployment wizard the deployment fails with an error message: Deployment Failed

Environment

SEP 14.3.x

Cause

Remote push deployment is failing while fetching/exporting the file fingerprint list whereas the push deployment is successful when attempting to push an existing package(already created package). 


RemotePushInstallClientWin-x.log outlines the following:

2024-03-19 15:34:49.079 THREAD 23 FINEST: PackageExportUtil> exportAppliedImage>> ComputerImage id: 400FCBA17BC64907AA0A4B814AA85E73, ClientBinaryFile count: 0
2024-03-19 15:34:49.079 THREAD 23 SEVERE: PackageExportUtil> exportAppliedImage>> could not get fingerprint list filenames from the client binary files, need to wait for it be filled in the package publish task.
2024-03-19 15:34:49.079 THREAD 23 FINEST: RemotePushInstallClientWinHandler> preparePackage>> copying allow list files finished with result: false
2024-03-19 15:34:49.079 THREAD 23 FINE: getConnectionFromDataSource: attempt:  1
 

Resolution

To resolve the issue

Remove the file fingerprint list added to the specific group during the deployment. 
Group -> Policies tab -> System Lockdown -> File Fingerprint List -> Select the File Fingerprint list added -> Remove

[AND/OR]

Ensure the Best practices for importing file fingerprint lists for SEP 14.3 RU5 and later are implemented with the imported list: 
https://techdocs.broadcom.com/us/en/symantec-security-software/endpoint-security-and-management/endpoint-protection/all/Using-policies-to-manage-security/about-application-control-system-lockdown-and-devi-v36534292-d45e176/configuring-system-lockdown-v35628639-d45e1550/best-practices-for-importing-file-fingerprint-lists-for-143-ru5-and-later.html