エラーメッセージ "Too many open files" に対してオープンファイル数の最大値を増やす方法
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エラーメッセージ "Too many open files" に対してオープンファイル数の最大値を増やす方法

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Article ID: 281461

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CA API Gateway

Issue/Introduction

API Gateway でトランザクションの処理が失敗し、ログにエラー "Too many open files" が表示される場合があります。

Environment

これは OS 設定の問題であり、API Gateway のすべてのバージョンに当てはまります。

Cause

オペレーティングシステムで現在の最大オープンファイル上限に達しました。これは通常、SSG サービスの使用量が、OS が許可したデフォルトの使用量を超えていることを意味します。言い換えれば、アプライアンスは現在のサービスの使用量が適切でない状況です。

Resolution

このエラー "Too many open files" に対処するには、次の手順に従います。

  1. ファイル 99-ssg-appliance.conf/etc/security/limits.d/ に存在する必要があります(存在しない場合は作成します)。

  2. 同ファイルの内容は以下のとおりであることを確認します。

    # Layer 7 Limits (SSG-8322)

    # gateway user value based on /proc/sys/kernel/pid_max
    *               hard    maxlogins    10
    *               hard    core    0
    *               soft    nproc   5120
    *               hard    nproc   16384
    *               soft    nofile  4096
    *               hard    nofile  63536
    gateway         soft    nproc   63536
    gateway         hard    nproc   63536
    # End Layer 7 Limits

  3. 次のコマンドを使用して、同ファイルの権限が 644 であることを確認します:
    chmod 644 /etc/security/limits.d/99-ssg-appliance.conf

  4. 新しいファイルを作成した後、または上記の手順 2 で内容を更新した後、ノード全体 (SSG サービスだけでなく) を再起動します。このファイルはオペレーティング システム (RHEL) の起動プロセス中にのみ読み取られるためです。

Additional Information

Keep-Alive が使用されている場合は、同エラーのトラブルシューティングとして KB 281462 をご参照ください。

[英文文書] Layer7 API Gateway: How to increase the maximum file open limit when receiving a "Too many open files"