Spectrum upgrade on Windows is failing
search cancel

Spectrum upgrade on Windows is failing

book

Article ID: 281442

calendar_today

Updated On:

Products

Network Observability Spectrum

Issue/Introduction

Spectrum upgrade from 23.3.2 to either 23.3.3, 23.3.4, and 23.3.7 is failiing.

No error by clicking on the View Logs button...

 

Enabled the InstallAnywhere in debug mode.

While the InstallAnywhere screen is in progress, hold down the CTRL-key. Once the progress dialog disappears release the CTRL-key.

The following error was displayed when the upgrade failed:

Stderr: IDcapi::read_data error: An established connection was aborted by the software in your host machine.

Stderr: IDcapi::read_data error: An existing connection was forcibly closed by the remote host.

Stderr: Remote execute failed: no error string returned

Environment

Spectrum in Windows platform.

Cause

It looks like the Spectrum Remote Administration SRAdmin is causing the issue.

The SRAdmin is no longer listening on port 46517:

netstat -ano | findstr 46517

When ran the Spectrum installer as Administrator another error was logged in the InstallAnywhere debug mode:

stderr SPC-INT-20071: The SRAdmin on <SpectroSERVER_hostname> is not at the latest version and cannot be automatically upgraded, pelase upgrade manually.

Resolution

Uninstalled the SR Admin (Spectrum Remote Administration) in the Windows Control Panel. Then installed the SR Admin and successfully upgraded Spectrum.