DX NetOps Spectrum Oneclick Administration page gives timeout after 3 minutes
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DX NetOps Spectrum Oneclick Administration page gives timeout after 3 minutes

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Article ID: 281394

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Updated On:

Products

Network Observability Spectrum

Issue/Introduction

You get a timeout after 3 minutes in the DX NetOps Spectrum Oneclick Administration page.

  • Timeout configuration is set to default but you still get timeouts.
  • The timeouts are difficult when doing some debugging.

Enable Inactive OneClick Client Timeout

  • You can configure Spectrum to check OneClick clients for inactivity and time out those clients that have been inactive for a specified amount of time using the settings in the OneClick Client Inactivity section of the OneClick Client Configuration page. These settings can enhance network security. For example, if a user leaves the OneClick client running unattended on a desktop, it times out.

Follow these steps:

  1. From the Administration page, click OneClick Client Configuration

    The OneClick Client Configuration page opens.
  2. Complete the settings in the OneClick Client Inactivity section as needed:
    • OneClick Client Inactivity Timeout (minutes)
      Specifies the number of minutes of inactivity to allow before timing out (logging off) a OneClick client.

Environment

23.3.x, 22,2.x

Cause

Session timeout value is not 0.

Resolution

  1. Set session timeout as zero(0) in /tomcat/conf/web.xml as below 
    =================================
    <session-config>
    <session-timeout>0</session-timeout>
    </session-config>
    ================================
  2. Restart tomcat
  3. Now the webpage will not timeout