AdminUI service will not start, "Failed to connect to LDAP directory"
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AdminUI service will not start, "Failed to connect to LDAP directory"

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Article ID: 281301

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Updated On:

Products

SITEMINDER

Issue/Introduction

Attempting to start the adminUI service, in the server.log you see the following errors.

"Failed to connect to LDAP directory ldap://example:1234"

and

"Failed to establish connection to directory: CA Directory---xxxxxxxxxxx"

Environment

Policy server: 12.8.x

AdminUI: 12.8.x

Cause

Re-registering the adminUI allows the service to start and allows access to the web interface with the siteminder user but after adding Administrative Authentication the error returns.

Resolution

  1. Check to make sure there is connectivity between the adminUI server and the directory server. Use a tool such as ldapsearch or jXplorer to confirm an LDAP connection can be made.
  2. Check the connection details of the Administrative Authentication server. Both the host and failover servers should have a hostname or IP and the hostname must be resolvable.