"Unable to connect to the database" error during upgrade
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"Unable to connect to the database" error during upgrade

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Article ID: 281284

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Updated On:

Products

Endpoint Security Complete

Issue/Introduction

When upgrading the Symantec Endpoint Protection Manager (SEPM), after the install completes, an error saying that it is unable to connect to the database is shown. The Management Server Upgrade window is never shown. 

The <SEPM install path>\tomcat\logs\Upgrade-0.log shows the error:

InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty

Environment

SEPM

Cause

The upgrade may have been run by a limited administrator or administrator that is a member of other groups which are limited.

Resolution

To resolve this issue, perform the following:

  1. Login as a local Administrator that is ONLY a member of the local Administrators group

  2. Edit <SEPM install path>\tomcat\conf\Catalina\localhost\ROOT.xml with notepad.

  3. Change "trustServerCertificate=false" to "trustServerCertificate=true" and save the file

  4. Run <SEPM install path>\bin\upgrade.bat to complete the installation