What does "message not routable, ending conversation" mean in the hub log?
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What does "message not routable, ending conversation" mean in the hub log?

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Article ID: 281273

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I am seeing this sequence over and over in a hub log.  Is it meaningful, or does it indicate a problem?

May 21 08:42:34:422 [140520265221888] hub: TSESS-A-2575-52 [<hubname>] local     100 'subscribe'
May 21 08:42:34:422 [140520265221888] hub: TSESS-A-2575-52 [<hubname>] sent     100 'subscribe' (479 bytes, 0 ms)
May 21 08:42:34:457 [140520265221888] hub: TSESS-A-2575-52 [<hubname>] ssl      299 '-' (51 bytes)
May 21 08:42:34:457 [140520265221888] hub: TSESS-A-2575-52 [<hubname>] received 299 '-' (59 bytes)
May 21 08:42:34:463 [140520265221888] hub: TSESS-A-2575-52 [<hubname>] message not routable, ending conversation
May 21 08:42:34:463 [140520265221888] hub: TSESS-A-2575-52 [<hubname>] suspended

Cause

Renamed hub / old queue

Resolution

This message occurs when there is a queue on an 'upstream' hub configured to point to a 'downstream' hub that no longer exists, most often as the result of a hub being renamed but the old queue left in place.

This can also occur as a result of the temporary hub queues from discovery_server trying to connect to a hub that no longer exists (usually due to renaming.)

To resolve this issue, take the following steps:

1. Restart discovery_server to clear its cached list of hubs.
2. If the message persists, check for any GET queues in your environment that are in a red/failed state because they're pointing to a nonexistent hub.  Delete those queues.