SMP Server has a duplicated communication profile after migrating to a new server
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SMP Server has a duplicated communication profile after migrating to a new server

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Article ID: 281242

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Updated On:

Products

IT Management Suite

Issue/Introduction

You have recently migrated to a new SMP Server. Keeping the same database but with a new hostname (as described in Migrating a Stand-Alone ITMS 8.5 RU4 Instance to the Latest ITMS Version)

After the migration was done, you also have made the SMP Server as a Task Server. After that, SMP Server has a duplicated communication profile (one under Site Server Communication Profiles and another as the default one under Agent Communication Profile):

Settings > Agents / Plug-ins > Symantec Management Agent > Site Server Communication profiles

Users are unable to delete (right-click > delete) duplicate communication profiles on their SMP Server under Site Server Communication Profiles.

If we try to make a change on any of them, you get a message like:

Existing profile 'name of the server' contains the same FQDN and web application path. Existence of non-unique profiles can lead to connection problems if some outdated profile will be used by the NS agent.

Environment

ITMS 8.x

Cause

SMP Server must not create a site server profile for site server that is located on the SMP Server itself. It must be some glitch with settings after the offbox upgrade.

Resolution

Browse to Settings > Agents / Plug-ins > Symantec Management Agent Communication Profiles > Site Server Communication profiles

  1. Identify the correct duplicate profile (be sure that this profile is not currently in use by agents/site servers)
  2. Right-click on the communication profile and select "Properties"
  3. Copy the GUID of the communication profile
  4. Paste the following query into SQL and run, replacing the capitalized section with the appropriate GUID:

    Update Item
    set Attributes = 0
    where Guid = 'GUID OF PROFILE TO DELETE'

  5. Go back to the communication profile page, refresh, and you can then right-click and delete the profile

IF the delete option is still not available after running the query above, try the following: 

  1. Using the same GUID as the step 3 above, add it to the ItemToDelete table:

Update Item
set Attributes = 0
where Guid = 'GUID OF PROFILE TO DELETE'

Then:

insert into ItemToDelete 
select  guid, GETDATE() 
from item where guid = 'GUID OF PROFILE TO DELETE'

After the NS.Quarter Hour schedule runs the item will be removed from the database.

 

If after the Symantec Management Agent on your SMP Server sends its Basic Inventory you see again a duplicate communication profile under the Site Server Communication profiles, do the following:

  1. On your SMP Server, under HKLM\Software\Altiris\Communications\ConnectionProfiles, find the entry with the same GUID as the duplicated communication profile and deleted it.
  2. Under HKLM\Software\Altiris\Communications\Servers, delete entries with your SMP Server name.
  3. Repeat the steps above for cleaning up the duplicate communication profile from the database.
  4. Check the following just in case:

    i. Run the following query on your database (here must be only 1 entry):
    select * from ServerSettingGuids
    where Name = 'NSResourceGuid'

    Keep note of the GUID returned.

    ii. On the SMP Console, go to Settings>Notification Server>Core Settings and search for: NSResourceGuid

    Keep note of the GUID for this setting.

    iii. On the Agent UI on your SMP Server, look for the "Computer ID" under the "Agent Settings" tab.
    Keep note of the GUID for  "Computer ID".


    It must be the same GUID in all places.

  5. If any of the GUIDs above are different, do the following:

    This option refers when you want to keep the value already present in the Symantec Management Agent UI but the one in the database and the one in the Coresettings.config is different.

    1. Please compare these two GUIDs: Symantec Management Agent (SMA) GUID displayed in the SMA UI on the Agent Setting page, and CoreSettings.config "NSResourceGuid" key. This is located (by default) at: C:\ProgramData\Symantec\SMP\Settings. You will need to find string "NSResourceGuid" inside the .config file and compare it with the GUID we see in the SMA UI settings page.
    2. If the GUIDs are different then you will need to replace the "NSResourceGuid" key in CoreSettings.config with the SMA GUID.
    3. On the database, you will need to update "ServerSettingsGuid" table:
      update ServerSettingGuids
      set value = 'addSMA_GUIDhere'
      where Name = 'NSResourceGuid
    4. After replacing the values, restart the Altiris Service, Symantec Management Agent service, Altiris Object Host Service and Altiris Client Task Data Loader Service.