Error: "The Thread is Already in Background Processing Mode (0x80070190)" when Task Registration Fails
book
Article ID: 281194
calendar_today
Updated On:
Products
Client Management SuiteIT Management Suite
Issue/Introduction
Endpoints are not registering to their task server and the task server in this situation is most likely the Symantec Management Platform (SMP) server itself.
Your endpoint may show something like the following image:
Failed to update configuration Error: The thread is already in background processing mode (0x80070190)
When reviewing the SMP server you may see that the registration to itself is also not working. You also may see something similar to the following image:
Failed to update configuration Error: HTTP error occurred (0x80042D21)
Environment
ITMS 8.x
Cause
Increased SMP logging verbosities in addition to extended verbosities.
Resolution
To verify this issue you may work through the following steps:
The console is accessible and responsive when navigating it. The URL to access the console is http://localhost/Altiris/NS.
When attempting to navigate to http://localhost/Altiris/NS/Agent it never loads. The expected response should be an immediate error.
In IIS Management if you navigate to Application Pools, find the Symantec Agent AppPool, right click it and choose recycle, now agent registration happens without a problem.
You may also notice that there are no NSEs processing on the SMP server in C:\ProgramData\Symantec\SMP\EventQueue\EvtQueue. In a functioning production SMP server you would normally see files quickly moving in and out of that directory.
You may have a backup of NSE files locally on the endpoint under C:\Program Files\Altiris\Altiris Agent\Queue\SMP.example.com
Resolution
On the SMP server open the Altiris Log Viewer by right clicking it and choosing to run as administrator
Click on Options and choose Log Options
You should only have Errors, Warnings, and Informational checked. If Trace, Verbose and Debug are checked, then uncheck them.
Click on Options and choose Extended Verbosities
Start by clicking on SMP Core and then use the keyboard combination of CTRL and click Apply. This will set the values back to default values. You may need to go through all extended verbosities to reset them back to default.
Monitor the SMP server and you should see operations return to normal