Credential Provider stopped after enabling Google reCAPTCHA for Identity Portal.
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Credential Provider stopped after enabling Google reCAPTCHA for Identity Portal.

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Article ID: 281134

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Updated On:

Products

CA Identity Suite

Issue/Introduction

Credential Provider is setup and is pointing to the Portal Forgotten Password URL

http://Portal_IPADDRESS:8081/sigma/public/index#/forgot-password 

Credential Provider worked as expected until Google reCAPTCHA is configured in Identity Portal.  


Using the out of the box configuration for the ALLOW and DENY rule strings:



ALLOW = (^http://Portal_IPADDRESS:8081|^https://google\.com|^C:\\Program Files\\CA\\Identity Manager\\Credential Provider\\404\.html|^unreachable\.html)

DENY = .*

Environment

Identity Manager 14.x 

Cause

the integration with Google recaptcha is referencing or otherwise resulting in an about:blank page which gets denied by the .* DENY string.  

Resolution

Looking in the Cube Browser logs, we see the a deny match on 'about:blank' 

Cube :: there are close rules processing them
Cube :: there are deny rules processing them
Cube :: we matched a deny rule: .* in about:blank
Cube :: there are allow rules processing them
Cube :: there are deny rules processing them
Cube :: we matched a deny rule: .* in about:blank

 

Add |^about:blank to your regex string in the ALLOW list: